Mikrotik. Как не потерять связь с устройством при удаленной настройке

Микротики – потрясающе функциональные устройства за свои деньги, обладающие рядом уникальных функций, например Safe Mode, которая просто незаменима при удаленной настройке устройств и может спасти и от кривых рук и от незнания каких то вещей при настройке. Но что делать, если руки прямые, но настраивать надо, например если требуется настроить ответную точку доступа WiFi моста?

Вернуть неправильно выполненную конфигурацию можно с помощью скриптов.

Сам скрипт банально прост и включает всего лишь команду восстановления резервной копии с задержкой по выполнению.

Тут важно узнать, имеет ли ваш Мироктик встроенную память или нет.
Если не имеет, то файл бэкапа надо класть и восстанавливать из папки flash.
Иначе, сохраняем и восстанавливаем прямо из корня.

Алгоритм действий если Микротик имеет встроенную память, то есть НЕТ папки flash.

1. Создаем скрипт восстановления сохраненной конфигурации через terminal:

/system script
add dont-require-permissions=no name=restore-from-backup.backup policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="\
	delay 600\r\
	\n/system backup load name=backup.backup password=123456788"

Где delay 600 – время задержки выполнения скрипта в секундах, у нас 10 минут.

Либо, через Winbox:

2. Создаем резервную копию конфигурации:

/system backup save name=backup password=123456788

Либо через Winbox-Files-Backup:

Обязательно установить пароль на файл, иначе скрипт не сможет восстановить его!

3. В Winbox нажимаем System-Scripts-Run Script, увидим что счетчик Run Count тикнет на единицу и это значит что время пошло и через заданный промежуток роутер восстановит указанную конфигурацию:

За это время можем производить настройку роутера и, если сделаете что то не так и потеряем связь с ним, то после восстановления конфигурации сможем попасть на роутер обратно.

4. Если вы уверены что сделали все что хотели верно, то удалить назначенное задание восстановления вы можете на соседней вкладке Jobs:

Если вы перезагрузите Микротик во время выполнения скрипта, то он выполнен не будет!

Алгоритм действий если Микротик не имеет встроенной памяти, то есть ЕСТЬ папка flash.

1. Создаем скрипт восстановления сохраненной конфигурации через terminal:

/system script
add dont-require-permissions=no name=restore-from-backup.backup policy=\
    ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source="\
	delay 600\r\
	\n/system backup load name=flash/backup.backup password=123456788"

Где delay 600 – время задержки выполнения скрипта в секундах, у нас 10 минут.

Либо, через Winbox:

2. Создаем резервную копию конфигурации:

/system backup save name=flash/backup password=123456788

Либо через Winbox-Files-Backup:

Обязательно установить пароль на файл, иначе скрипт не сможет восстановить его!
Проследите за тем, чтобы файл сохранился именно в папке flash, иначе после перезагрузки он пропадет.

3. В Winbox нажимаем System-Scripts-Run Script, увидим что счетчик Run Count тикнет на единицу и это значит что время пошло и через заданный промежуток роутер восстановит указанную конфигурацию:

За это время можем производить настройку роутера и, если сделаете что то не так и потеряем связь с ним, то после восстановления конфигурации сможем попасть на роутер обратно.

4. Если вы уверены что сделали все что хотели верно, то удалить назначенное задание восстановления вы можете на соседней вкладке Jobs:

Если вы перезагрузите Микротик во время выполнения скрипта, то он выполнен не будет!

Ссылки

https://ixnfo.com/bezopasnaya-udalennaya-rabota-s-mikrotik-kak-ne-poteryat-svyaz-s-ustroystvom.html

http://mikrotik-ukraine.blogspot.com/2015/12/blog-post_27.html

Оставьте ответ

Ваш адрес email не будет опубликован.

56 ÷ = 7