Mikrotik. Backup конфигурации и настроек на электронную почту.

Сделаем, чтобы Микротик отсылал на почту бэкап своих настроек в виде .rsc и .backup файлов. Очень полезно как в качестве резервирования, так и чтобы иметь возможность сверить изменения в конфигурациях за период времени.

Приятность в том, что одна и та же настройка будет работать и на роутерах и на коммутаторах в силу гомогенности ОС. Скрипт проверялся и на 6 и на 7 версии ROS.

Настройка почты для отправки

Во первых, настроим то, чем Микрот будет отсылать файлы, Tools-Email, все по смыслу:

Скрипт бэкапа конфигурации Микротик

Во вторых, настроим скрипт, который будет снимать конфигурацию и отправлять по почте. System-Scripts:

:local backupfile ([/system identity get name] ."-" . [:pick [/system clock get date] 7 11] ."-" . [:pick [/system clock get date] 0 3] ."-" . [:pick [/system clock get date] 4 6] . ".backup");
:local exportfile ([/system identity get name] ."-" . [:pick [/system clock get date] 7 11] ."-" . [:pick [/system clock get date] 0 3] ."-" . [:pick [/system clock get date] 4 6] . ".rsc");
/system backup save dont-encrypt=yes name=$backupfile;
:delay 5;
/export file=$exportfile;
:delay 5;
:local date [/system clock get date];
:local body1 "$date IDENTITY backup";
:local body2 "$date IDENTITY conf export";
/tool e-mail send to="email@email.com" body="$body1" subject="$body1" file=$backupfile;
:delay 5;
/tool e-mail send to="email@email.com" body="$body2" subject="$body2" file=$exportfile;
:delay 5;
/file remove $backupfile;
/file remove $exportfile;
:log warning "backup, export e-mail finished";

Жирное замените на своё.

Тут же сразу можно нажать Run Script и проверить его работу.

В логах смотрим удачно или нет скрипт выполняется.

Настройка расписания запуска скрипта

В третьих, добавляем скрипт в загрузку по расписанию. System-Schedule:

Вуаля, теперь каждую неделю на почте свежий бэкап роутера.

Оставьте ответ

Ваш адрес email не будет опубликован.

÷ 3 = 2