Настройка FreePBX за роутером Mikrotik

Настройка Mikrotik

/ip firewall filter
add action=accept chain=forward comment=”voip asterisk” dst-port=5060-5065,5160,4569,10000-20000 in-interface=bridge_wan protocol=udp src-address-list=voip
add action=accept chain=forward dst-address-list=voip dst-port=”” out-interface=bridge_wan protocol=udp src-port=5060-5065,5160,4569,10000-20000

/ip firewall nat
add action=dst-nat chain=dstnat comment=”FREEPBX SIP” dst-port=5060-5065,5160,4569,10000-20000 in-interface=bridge_wan protocol=udp src-address-list=voip to-addresses=XXX.XXX.XXX.XXX

/ip firewall address-list
add address=sip.zebra.ru list=voip
add address=sip.zadarma.ru list=voip

/ip firewall service-port
set ftp disabled=yes
set tftp disabled=yes
set irc disabled=yes
set h323 disabled=yes
set sip disabled=yes ports=5060,5061,5160 sip-direct-media=no
set pptp disabled=yes
set udplite disabled=yes
set dccp disabled=yes
set sctp disabled=yes

Настройка FREEPBX

ВНИМАНИЕ ВАЖНО!

disallow=all
allow=alaw
allow=ulaw

в настройках Транка до провайдера правильно подобрать кодеки

Далее …

Файл sip_general_additional.conf Вкладка NAT ( Смотриеть картинку )

;——————————————————————————–;
;          Do NOT edit this file as it is auto-generated by FreePBX.             ;
;——————————————————————————–;
; For information on adding additional paramaters to this file, please visit the ;
; FreePBX.org wiki page, or ask on IRC. This file was created by the new FreePBX ;
; BMO – Big Module Object. Any similarity in naming with BMO from Adventure Time ;
; is totally deliberate.                                                         ;
;——————————————————————————–;
faxdetect=no
useragent=FPBX-14.0.13.4(13.22.0)
language=ru
disallow=all
allow=alaw
allow=ulaw
context=from-sip-external
callerid=Unknown
notifyringing=yes
notifyhold=yes
tos_sip=cs3
tos_audio=ef
tos_video=af41
alwaysauthreject=yes
limitonpeers=yes
allowguest=no
progressinband=yes
prematuremedia=no
rtpend=20000
context=from-sip-external
callerid=Unknown
rtpstart=10000
tcpenable=no
callevents=yes
bindport=5160
jbenable=no
checkmwi=10
maxexpiry=3600
minexpiry=60
srvlookup=no
tlsenable=no
allowguest=no
notifyhold=yes
rtptimeout=30
canreinvite=no
tlsbindaddr=[::]:5161
rtpkeepalive=0
videosupport=no
defaultexpiry=120
notifyringing=yes
maxcallbitrate=384
rtpholdtimeout=300
g726nonstandard=no
registertimeout=20
tlsclientmethod=tlsv1
registerattempts=0
nat=no
ALLOW_SIP_ANON=no
tlscafile=/etc/pki/tls/certs/ca-bundle.crt
localnet=XXX.XXX.XXX.XXX/24

Ссылки

https://www.prochor.ru/content/nashi-stati/asterisk_st/content1/nastrojka-freepbx-za-routerom-mikrotik.html

Оставьте ответ

Ваш адрес email не будет опубликован.

88 ÷ = 11